Requires installation of untrusted packages?

1

rick@rick-laptop:~$ sudo rm /var/lib/apt/lists/* -vf

[sudo] password for rick:

Sorry, try again.

[sudo] password for rick:

removed `/var/lib/apt/lists/ca.archive.ubuntu.com_ubuntu_dists_lucid_main_bina ry-i386_Packages'

removed `/var/lib/apt/lists/ca.archive.ubuntu.com_ubuntu_dists_lucid_main_i18n _Translation-en%5fCA'

removed `/var/lib/apt/lists/ca.archive.ubuntu.com_ubuntu_dists_lucid_main_sour ce_Sources'

removed `/var/lib/apt/lists/ca.archive.ubuntu.com_ubuntu_dists_lucid_multivers e_binary-i386_Packages'

removed `/var/lib/apt/lists/ca.archive.ubuntu.com_ubuntu_dists_lucid_multivers e_source_Sources'

removed `/var/lib/apt/lists/ca.archive.ubuntu.com_ubuntu_dists_lucid_Release'

removed `/var/lib/apt/lists/ca.archive.ubuntu.com_ubuntu_dists_lucid_restricte d_binary-i386_Packages'

removed `/var/lib/apt/lists/ca.archive.ubuntu.com_ubuntu_dists_lucid_restricte...

0 0
2

One of the first things I did after I got my Lenovo IdeaPad Y560 was to make it dual boot to Windows 7 and Ubuntu. After I have installed Ubuntu, I immediately run the Update Manager to update the system. Btw, I always update the system (either Windows or Ubuntu) before I install any programs or do any customizations. This makes sure that all components are up-to-date and helps make the system run smoother and lessens the chances of errors or conflicts with other components.

Anyways, when I tried to download and install the available updates for Ubuntu, I got this error message:

Requires installation of untrusted packages – “The action would require the installation of packages from not authenticated sources.”

I’ve installed Ubuntu lots of times before and this was the first time that I encountered this issue/error. I Googled the error message and found the very short and very simple solution from the Ubuntu forums. I’m sharing this in case someone might...

0 0
3

I tried installing VLC Player yesterday, and I got the Requires installation of untrusted packages error. I searched for hours for a solution to this problem, and finally came upon a suggestion that said to change servers for downloading updates from. I did this, and it gave me a 404 error when I clicked on "Check" in the Update Manager. I tried switching my server back to the main one (and after that, several other ones), but I am now still getting a 404 error:

And the other error I get when downloading or updating:

Edit: Output of cat /etc/apt/sources.list:

deb-src http://us.archive.ubuntu.com/ubuntu/ precise main restricted #Added by software-properties # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to # newer versions of the distribution. deb http://us.archive.ubuntu.com/ubuntu/ precise main restricted multiverse deb-src http://us.archive.ubuntu.com/ubuntu/ precise multiverse universe #Added by software-properties ## Major bug fix...
0 0
4

@orschiro

Hello! Here is the contents of /etc/apt/ source.list:

# deb cdrom:[Ubuntu-MATE 16.04.2 LTS _Xenial Xerus_ - Release i386 (20170215)]/ xenial main multiverse restricted universe # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to # newer versions of the distribution. deb http://archive.ubuntu.com/ubuntu xenial main restricted deb-src http://archive.ubuntu.com/ubuntu xenial universe restricted main multiverse #Added by software-properties # deb-src http://ph.archive.ubuntu.com/ubuntu/ xenial main restricted ## Major bug fix updates produced after the final release of the ## distribution. deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted deb-src http://archive.ubuntu.com/ubuntu xenial-updates universe restricted main multiverse #Added by software-properties # deb-src http://ph.archive.ubuntu.com/ubuntu/ xenial-updates main restricted ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu ## team. Also,...
0 0
5


Question:

I tried installing VLC Player yesterday, and I got the Requires installation of untrusted packages error. I searched for hours for a solution to this problem, and finally came upon a suggestion that said to change servers for downloading updates from. I did this, and it gave me a 404 error when I clicked on "Check" in the Update Manager. I tried switching my server back to the main one (and after that, several other ones), but I am now still getting a 404 error:

And the other error I get when downloading or updating:

Edit: Output of cat /etc/apt/sources.list:

deb-src http://us.archive.ubuntu.com/ubuntu/ precise main restricted #Added by software-properties # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to # newer versions of the distribution. deb http://us.archive.ubuntu.com/ubuntu/ precise main restricted multiverse deb-src http://us.archive.ubuntu.com/ubuntu/ precise multiverse universe #Added by...
0 0
6
requires installation of untrusted packages - Page 1 - AirySoftware

Speed up you PC 300%

Home

>

requires installation of untrusted packagesQuickstart — IPython 3.2.1 documentation Rating:2/10http://ipython.org/ipython-doc/dev/install/install.html This will download and install IPython and its main optional dependencies for the notebook, qtconsole, tests, and other functionality. Some dependencies (Qt, PyQt for ... Location: Phoenix, Arizona, United States Requires installation of untrusted packages? - Ask Ubuntu Rating:6/10https://askubuntu.com/questions/184...es-installation-of-untrusted-packages Sep 4, 2012 - Based on the errors you pasted in the comments section of my previous answer, I have another possible solution: sudo apt-get clean cd ... Location: San Francisco, California, United States Requirements — Cuckoo Sandbox v2.0.0 Book ...
0 0
7

I tried to install Skype on Ubuntu 10.04 and I received the following error:

Requires installation of untrusted packages The action would require the installation of packages from not authenticated sources. Details : gcc-4.6-base:i386 libaudio2:i386 libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386 libcomerr2:i386 libffi6:i386 libgcc1:i386 libgpg-error0:i386 libgstreamer0.10-0:i386 libice6:i386 libjpeg8:i386 libkeyutils1:i386 liblcms1:i386 libmng1:i386 liborc-0.4-0:i386 libp11-kit0:i386 libpcre3:i386 libpng12-0:i386 libqtwebkit4:i386 libselinux1:i386 libsm6:i386 libstdc++6:i386 libuuid1:i386 libx11-6:i386 libxau6:i386 libxdmcp6:i386 libxext6:i386 libxi6:i386 libxrender1:i386 libxss1:i386 libxt6:i386 libxv1:i386 zlib1g:i386

How can I fix it?

I hope this will lead you further click here for detailed information

Mind you: I've never tested this solution, since I don't use Skype. But it should work according to the Wiki

Succes !

To...

0 0
8

Packages

Questions

Q: How do I deal with "unauthenticated sources" errors in the Software Center?

Tags: packages (Next Q)

Any install that I'm trying through the Software Center is telling me:

Requires installation of untrusted packages: The action would require the installation of packages from not authenticated sources.

I did an apt-get update from the command line, then removed the software sources that the keys were bad from (PPAs I added myself), and unchecked them in the software sources for software center, but to no avail. I can't install anything from software center anymore - only> from the command line with apt-get.

Is uninstalling/installing the only option? I don't want to break other PPAs that I have.

Additional information:

Here's a paste from apt-get update:

Reading package lists... Done

W: GPG error: http://ppa.launchpad.net oneiric Release: The following signatures couldn't be verified...

0 0
9

--------------------------------------------

On Fri, 11/3/16, Karl Auer wrote:

Subject: Re: "Required Installation of Untrusted packages"
To: ubuntu-***@lists.ubuntu.com
Date: Friday, 11 March, 2016, 13:53

On Fri, 2016-03-11 at

Installation of Untrusted packages"

installation of packages from not

authenticated sources.

It's quite common with PPA sources, but
perl probably isn't that. This
sometimes
happens when the sources list is out of date, so do this:

sudo apt-get update

... then try again.

Regards, K.

--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Karl Auer (***@biplane.com.au)

Thanks Karl,

Well how about that ! I was about to do what you instructed and tried just once
more to update via "synaptic" and it worked !

Go figure . . . .

Thank you though,

Regards,

s.
...

0 0
10
...
0 0
11
12.10 Software Center Requires installation of untrusted packages

location: ubuntuforums.com - date: April 22, 2013
I've been having major problems lately with the Ubuntu Software Center. Every time I try to install something, I get the message "Requires installation of untrusted packages" and gives me the options "ok" and "repair". If I click "ok", then the installation aborts and nothing happens. If I click "repair" I get the message "Failed to download repository information" with these details: Code: W:Failed to fetch http://security.ubuntu.com/ubuntu/di...ty/Release.gpg Something wicked happened resolving 'security.ubuntu.com:http' (-5 - No address associated with hostname), W:Failed to fetch cdrom://Ubuntu 12.10 _Quantal Quetzal_ - Release amd64 (20121017.5)/dists/quantal/main/binary-amd64/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs , W:Failed to fetch cdrom://Ubuntu 12.10 _Quantal Quetzal_ -...

0 0
12

This message is often appeared in your software center or with your synaptic. This problem can be solved by executing a single line command in shell.

If you've added PPA's (Personal Package Archives) to your software sources in Ubuntu, you may find you get an error when you try to run updates in the Update Manager.

‘Requires installation of untrusted packages’

This is typically owing to missing GPG keys for those PPA's so that Update Manager can't verify those updates. It will simply refure to install those updates. It is easy to fix.

go to :

Applications -> Terminal

Sudo apt-get update

The PPA's that are being refused will show up having no public key:

Output :

...

Ign http://extras.ubuntu.com oneiric/main Translation-en

Ign http://archive.canonical.com oneiric/partner Translation-en

Ign http://ppa.launchpad.net oneiric/main Translation-en_GB

Ign http://ppa.launchpad.net oneiric/main...

0 0
13

This is a common error with Software Center in nearly all the versions of Ubuntu.

If you've not updated your repository index for more than 3-4 days and then you try to install some software, you see this error message as the index has expired in the mean time. The installation doesn't succeed from Software Center, Synaptic or any other package manager including apt-get.

To solve the issue, all you need to do is to run this command from a Terminal under Applications > Accessories sub-menu.

sudo apt-get update

Or you can fire up Update Manager from under System > Administration sub-menu and click Check.

Once the update process is completed, go to Software Center, Synaptic or whichever package manager your want to use and your installation should complete successfully.

Software Center and other package managers should automatically refresh the index and but unfortunately, it needs some work by the developers at...

0 0
14

Before proceeding to installing and configuring Cuckoo, you’ll need to install some required software packages and libraries.

Installing Python libraries (on Ubuntu/Debian-based distributions)¶

The Cuckoo host components is completely written in Python, therefore it is required to have an appropriate version of Python installed. At this point we only fully support Python 2.7. Older version of Python and Python 3 versions are not supported by us (although Python 3 support is on our TODO list with a low priority).

The following software packages from the apt repositories are required to get Cuckoo to install and run properly:

$ sudo apt-get install python python-pip python-dev libffi-dev libssl-dev $ sudo apt-get install python-virtualenv python-setuptools $ sudo apt-get install libjpeg-dev zlib1g-dev swig

In order to use the Django-based Web Interface, MongoDB is required:

$ sudo apt-get install mongodb

In order to use PostgreSQL as database (our...

0 0
15

Introduction

Introduction

The 2011 CWE/SANS Top 25 Most Dangerous Software Errors is a list of the most widespread and critical errors that can lead to serious vulnerabilities in software. They are often easy to find, and easy to exploit. They are dangerous because they will frequently allow attackers to completely take over the software, steal data, or prevent the software from working at all.

The Top 25 list is a tool for education and awareness to help programmers to prevent the kinds of vulnerabilities that plague the software industry, by identifying and avoiding all-too-common mistakes that occur before software is even shipped. Software customers can use the same list to help them to ask for more secure software. Researchers in software security can use the Top 25 to focus on a narrow but important subset of all known security weaknesses. Finally, software managers and CIOs can use the Top 25 list as a measuring stick of progress in their efforts to...

0 0
16

The Visual C++ distribution targeted at Windows 2000 through Windows 8 does not provide any stock workspace (DSW) or project files (DSP) except for those included with third party libraries. Instead, there is a "configure" program that must run to create build environments to satisfy various requirements.

The configure program resides in VisualMagickconfigure in the GraphicsMagick source tree. A pre-compiled configure.exe is provided, as well as Visual Studio project files to recompile it from source code if needed.

Once started, the configure program provides this configuration dialog after proceeding past the initial notifications screen:

In addition to (or as a replacement to) the above dialog, the configure.exe program supports these command-line options:

/Q8 /Q16 /Q32 Set quantum depth /x64 Add x64 configuration /mtd /sts /mts /mtsd Set project type /noWizard Do not show the wizard /openMP Enable openMP

The Visual C++ system provides three different...

0 0
17

The VPN Posture (HostScan) Module provides the Cisco AnyConnect Secure Mobility Client the ability to identify the operating system, antivirus, antispyware, and firewall software installed on the host to the ASA.

The VPN Posture (HostScan) Module requires Hostscan to gather this information. Hostscan, available as its own software package, is periodically updated with new operating system, antivirus, antispyware, and firewall software information. The usual recommendation is to run the most recent version of HostScan (which is the same as the version of AnyConnect).

AnyConnect 4.5.x is incompatible with HostScan releases prior to HostScan 4.3.05017. AnyConnect 4.5.x is however backwards compatible with HostScan 4.3.05017, and you must use HostScan 4.3.05017 (or later HostScan 4.3.x releases) as the HostScan image in ASDM (Configuration > Remote Access VPN > Secure Desktop Manager > Host Scan image).

The List of Antivirus, Antispyware, and...

0 0
18

Is there a tutorial?

Read the lxml.etree Tutorial. While this is still work in progress (just as any good documentation), it provides an overview of the most important concepts in lxml.etree. If you want to help out, improving the tutorial is a very good place to start.

There is also a tutorial for ElementTree which works for lxml.etree. The documentation of the extended etree API also contains many examples for lxml.etree. Fredrik Lundh's element library contains a lot of nice recipes that show how to solve common tasks in ElementTree and lxml.etree. To learn using lxml.objectify, read the objectify documentation.

John Shipman has written another tutorial called Python XML processing with lxml that contains lots of examples. Liza Daly wrote a nice article about high-performance aspects when parsing large files with lxml.

Where can I find more documentation about lxml?

There is a lot of documentation on the web and also in the Python standard...

0 0