E: Unable to correct problems, you have held broken packages

1

I am trying to install ROS Indigo. I did the following steps:

$ sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu xenial main" > /etc/apt/sources.list.d/ros-latest.list' $ sudo apt-key adv --keyserver hkp://ha.pool.sks-keyservers.net:80 --recv-key 421C365BD9FF1F717815A3895523BAEEB01FA116 $ sudo apt-get update $ sudo apt-get install ros-kinetic-desktop-full

When I executed the last line, I've received the following error:

Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: ros-indigo-desktop-full : Depends: ros-indigo-desktop but it is not going to be installed Depends:...
0 0
2

I am running this command:

sudo apt install libqt5svg5-private-dev

I receive the error

Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libqt5svg5-private-dev : Depends: libqt5svg5-dev (= 5.2.1-1) but 5.5.1-2build1 is to be installed E: Unable to correct problems, you have held broken packages.

What can I do to resolve this problem? I have run apt install -f to no avail and also tried...

0 0
3

I tried to replicate your situation by doing the following:
1. install statler in virtual machine
2. install libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-ttf2.0-dev
3. edit /etc/apt/sources.list & /etc/apt/preferences to wheezy/waldorf
4. update & upgrade
5. edit /etc/apt/apt.conf to waldorf
6. install libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-ttf2.0-dev
And it worked. The packages were removed during the upgrade to waldorf, but installed normally afterwards.

I've encountered the error messages you posted after using apt-pinning to install package A from experimental, then trying to install package B, where package B, by default, would be downloaded from testing, but as a dependency of (or because of its dependency upon) package A, must also be downloaded from experimental.

That's all the help I can think of, maybe someone with more experience with apt can stop by and say...

0 0
4
Hi guys,

I'm a super noob, and I've been searching forums for the past few hours to try and find a solution to this problem, but I've had no luck and so I'm looking for some help.

I started having this error "E: Unable to correct problems, you have held broken packages." when I tried to reinstall Amarok through the terminal earlier, here's the script:

Code:

$ sudo apt-get install amarok Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies. amarok : Depends: kde-runtime but it is not going to be installed Depends: libkcmutils4 (>= 4:4.7) but it is not going to be installed Depends:...
0 0
5

When I finished installing ROS Indigo, I noticed that it already came with Gazebo(version2.2.6). If I directly install the 6.0 Gazebo, is it possible that the 6.0 version and 2.2.6 version will conflict with each other?

Actually, I have tried to install gazebo as described in http://gazebosim.org/tutorials?tut=in...

but, it says that : E: Unable to correct problems, you have held broken package

It looks like that I have Gazebo(version2.2.6) cause this problem (gazebo which command indicate tha I have Gazebo(version2.2.6)

How can I remove Gazebo(version2.2.6) came with ROS indigo?

My situation is as follows:

wkyoun@wkyoun-XPS-13-9343:~$ sudo apt-get install gazebo6 Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet...

0 0
6

Environment: bash on ubuntu on windows 10
I wanna to install all Kali tool and I choose "0"
Then it showed the following errors.
What shoud I do to repair it.
My environmrnt is the same as ubuntu 16.04 LTS

hope to get response from you !

'''
Select a category or press (0) to install all Kali linux tools .

kat > 0
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
arachni : Depends: phantomjs but it is not going to be installed
cutycapt : Depends: libqt5svg5 (>= 5.6.0beta) but it is not going to be installed
...

0 0
7

I have this raspberry PI 2, which I run Resilio and SSH for backups. I installed a couple of stuff without any issue (APCUPSD, web interface for APCUPSD, apache2).

I am trying to install RPI-Monitor and webmin, but I always get: E: Unable to correct problems, you have held broken packages.

Depends: libnet-ssleay-perl but it is not going to be installed Depends: libauthen-pam-perl but it is not going to be installed Depends: libio-pty-perl but it is not going to be installed Depends: apt-show-versions but it is not going to be installed

if I try to install them, i get this message:

The following packages have unmet dependencies: apt-show-versions : Depends: libapt-pkg-perl (>= 0.1.21) but it is not going to be installed libauthen-pam-perl : Depends: perlapi-5.14.2 libio-pty-perl : Depends: perlapi-5.14.2 libnet-ssleay-perl : Depends: perlapi-5.14.2 E: Unable to correct problems, you have held broken packages.

Any help would be...

0 0
8


Question:

I am using Ubuntu 13.04 which I installed few days back. I am trying to install nodejs and npm. I tried to install from command line first and then uninstalled it. Then something broke.

sudo apt-get install -f nodejs npm Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: nodejs : Conflicts: npm E: Unable to correct problems, you have held broken packages.

The output of /etc/apt/sources.list is below:

# deb cdrom:[Ubuntu 13.04 _Raring Ringtail_ - Release amd64 (20130424)]/ raring main restricted # See http://help.ubuntu.com/community/UpgradeNotes for how to...
0 0
9
...
0 0
10

The Problem

I am trying to install Dolphin Emulator but every time I try it gives me an error. Anything I try doesn’t work including many other thread’s solutions.

sudo apt-get install dolphin-emu Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help resolve the situation: The following packages have unmet dependencies: dolphin-emu : Depends : libstdc++6 (>= 4.9) but 4.8.4-2ubuntu1~14.04 is to be installed E: Unable to correct problems, you have held broken packages.

What I Have Tried

I have tried many other thread’s solutions to fix the problem. I have tried

sudo apt-get clean sudo apt-get autoclean sudo aptitude install dolphin-emu sudo apt-get update sudo...
0 0
11

I am using Ubuntu 13.04 which I installed few days back. I am trying to install nodejs and npm. I tried to install from command line first and then uninstalled it. Then something broke.

sudo apt-get install -f nodejs npm Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: nodejs : Conflicts: npm E: Unable to correct problems, you have held broken packages.

The output of /etc/apt/sources.list is below:

# deb cdrom:[Ubuntu 13.04 _Raring Ringtail_ - Release amd64 (20130424)]/ raring main restricted # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to # newer versions of the...
0 0
12

That particular error message may indicate that you have held packages, but it may also indicate a different problem.

You can get a list of actual held packages with:

dpkg --get-selections | grep hold

If there are none, or none look related, then it's probably something else. Check carefully the output of the command you were trying when you got the error message, as there may be other clues in the full output from that command, aside from the error message.

Another method of troubleshooting may be to use aptitude rather than apt-get to try to install your package:

sudo aptitude install

Aptitude will give up less easily, and will attempt to find solutions which may involve modifying other packages. It may give you more explanation of the problem and options for fixing it.

Occasionally aptitude will be too eager to remove or downgrade large numbers of packages to satisfy your request, in which case retrying with -f changes its priorities and helps...

0 0
13

You might find that when you’re trying to install a package on Linux you find a dreaded line that reads E: Unable to correct problems, you have held broken packages. The installation then refuses to progress beyond this point. You might find this on any Linux distribution that uses apt-get to manage packages, which includes Debian as well as the various Linux Mint and Ubuntu spin-offs.

It’s caused by broken dependencies, which are a side-effect from having packages installed that depend on other packages that aren’t installed. When apt-get goes to install something, it notices that it doesn’t have access to something that it needs and therefore can’t continue. A few basic command line tricks as well as a graphical tool can fix everything up quickly.

Method 1: Using dpkg –configure to Fix Held Broken Packages

While working at the terminal, trying running sudo dpkg –configure -a to start an automatic update process that looks for any broken dependencies on your...

0 0
14

trying to install this, I am getting the 'Unable to correct problems, you have held broken packages' error message.

Server version: Apache/2.4.2 (Ubuntu) Server built: Jun 27 2012 07:23:35

# aptitude install libapache2-mod-wsgi The following NEW packages will be installed: apache2.2-common{ab} libapache2-mod-wsgi 0 packages upgraded, 2 newly installed, 0 to remove and 0 not upgraded. Need to get 299 kB of archives. After unpacking 1,047 kB will be used. The following packages have unmet dependencies: apache2 : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed. apache2.2-common : Depends: apache2.2-bin (= 2.2.22-1ubuntu1.5) but it is not going to be installed. Depends: apache2-utils but it is not going to be installed. apache2-bin : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed. apache2-data : Conflicts: apache2.2-common but 2.2.22-1ubuntu1.5 is to be installed. The following actions will resolve these dependencies: ...
0 0
15

I've searched the solution but so far I did not get the right one I can apply.

Host: Ubuntu 14.04

when I typed the following command,

sudo apt-get install libxtst-dev:i386

I got the following error message:

Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libxtst-dev:i386 : Depends: libxext-dev:i386 but it is not going to be installed Depends: libxi-dev:i386 but it is not going to be installed E: Unable to correct problems, you have held broken packages.

And some other packages the same error.

Please let me know how to resolve these conflicts,...

0 0
16

IV> On Wed, Feb 1, 2012 at 5:14 AM, Abhishek Dixit

[hidden email]

> wrote:

IV> > sudo apt-get install kword

IV> > [sudo] password for deel:

IV> > Reading package lists... Done

IV> > Building dependency tree

IV> > Reading state information... Done

IV> > Some packages could not be installed. This may mean that you have

IV> > requested an impossible situation or if you are using the unstable

IV> > distribution that some required packages have not yet been created

IV> > or been moved out of Incoming.

IV> > The following information may help to resolve the situation:

IV> >

IV> > The following packages have unmet dependencies:

IV> > kword : Depends: koffice-libs (>= 1:2.3.3-0ubuntu6) but it is not

IV> > going to be installed

IV> > E: Unable to correct problems, you have held broken packages.

IV> >

IV> >

IV> > How can I fix above problem I used the apt-get...

0 0
17

I've got an Ubuntu 16.04 server in production on which I wanted to install node and npm. So I ran this:

sudo apt install nodejs nodejs-legacy npm

The nodejs-legacy package is solely meant to have a symlink for legacy Node.js code requiring the node binary to be /usr/bin/node (not /usr/bin/nodejs as provided in Debian). I found I need it to make node and npm work properly on Ubuntu.

I've run the apt install command above many times on fresh Ubuntu 16.04 servers, but on this production server I got the following error:

$ sudo apt install nodejs nodejs-legacy npm [sudo] password for kramer65: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:...
0 0
18

Package software-center not found on Ubuntu 14.04 LTS.

I tried to Install it via terminal, But ended up with below error :

ravip@LP204:~$ sudo apt-get install software-center [sudo] password for ravip: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: software-center : Depends: software-center-aptdaemon-plugins but it is not going to be installed Depends: python-gi but it is not going to be installed Depends: python-gi-cairo but it is not going to be installed Depends: python-aptdaemon (>= 0.40) but it is not going to be installed Depends:...
0 0